Student Administration - Major Outage

Incident Report for UMass Shared Services

Resolved

Student Administration outage has been resolved and is functioning properly.
Posted Jan 28, 2025 - 17:52 EST

Investigating

Student Administration is experiencing a major outage. We are urgently investigating the issue and apologize for the inconvenience. Users may experience issues logging into Student services.
Posted Jan 28, 2025 - 10:44 EST
This incident affected: Student Services (*Student Production (Boston, Dartmouth, Lowell)).