Service Interruption – HR Direct - Degraded Performance
Incident Report for UMass Shared Services
Resolved
RESTORED: HR Direct services have been restored and we will continue monitoring for any issues. If you encounter problems, please contact us. We appreciate your patience and apologize for any inconvenience.

QUESTIONS: Please contact the UMSO Help Desk or 774-528-0202 if you have any questions regarding this communication.
Posted Sep 29, 2023 - 15:12 EDT
Monitoring
MONITORING: We've stabilized the performance of the HR Direct application and will continue to monitor it until we can confirm a complete resolution. Please contact us if you're experiencing any problems with the application.

QUESTIONS: Please contact the UMSO Help Desk or 774-528-0202 if you have any questions regarding this communication.
Posted Sep 22, 2023 - 15:20 EDT
Investigating
WHAT: The HR Direct application is intermittently slow for some users. These users report experiencing slowness when navigating to HR Direct.

We are urgently investigating HR Direct and other applications. We apologize for the inconvenience.

WHEN: This was observed starting at approximately 5:00 p.m. on 09/21/23.

QUESTIONS: Please contact the UMSO Help Desk or 774-528-0202 if you have any questions regarding this communication.
Posted Sep 22, 2023 - 08:54 EDT
This incident affected: Human Resources (* HR Direct).