Finance HR and Student Application - PeopleSoft Reporting

Incident Report for UMass Shared Services

Resolved

Relevant changes have been successfully backed out and connectivity has been restored.

Thank you for your patience.
Posted Jun 29, 2026 - 13:01 EDT

Investigating

We are currently investigating a connection issue preventing reports from posting in PeopleSoft. This issue is impacting the Student, HR, and Finance systems. Updates will be provided as more information becomes available.
Posted Jun 29, 2026 - 12:35 EDT
This incident affected: Human Resources (* HR Direct), Student Services (*Student Production (Boston, Dartmouth, Lowell)), Finance Systems (* Finance Production), and International Services (* Sunapsis).