Summit - Batch Running Late
Incident Report for UMass Shared Services
Resolved
Service is available.
Posted Jun 11, 2024 - 19:10 EDT
Investigating
Please note: Summit HR batch is running late. An update will follow at 9AM.
Posted Jun 11, 2024 - 05:55 EDT
This incident affected: Summit (* Summit - HR).