Multiple Applications - Degraded Performance
Incident Report for UMass Shared Services
Resolved
Steps were taken to resolve the issue and the performance of the applications has improved. We will continue to closely monitor the applications. We apologize for the inconvenience.
Posted Mar 21, 2023 - 12:16 EDT
Investigating
We are receiving reports of slowness in multiple applications when establishing new connections or navigating, including HR Direct, Finance, Student (Boston, Dartmouth, Lowell), and Summit. We are urgently investigating and apologize for any inconvenience.
Posted Mar 21, 2023 - 10:46 EDT
This incident affected: Human Resources (* HR Direct), Student Services (*Student Production (Boston, Dartmouth, Lowell)), Finance Systems (* Finance Production), and Summit (* Summit - Finance, * Summit - HR, * Summit - Student, * Summit - Executive, * Summit - Tableau).