SalesForce Case Creation Degraded

Incident Report for UMass Shared Services

Identified

UITS can confirm that SalesForce is actively troubleshooting a large-scale problem with email handling. This issue is impacting a large swath of North American customers. At this time, tickets are not being created if they originate from an email. Addtionally, emails being sent from within SalesForce are not being received. We will continue to monitor the progress and will update accordingly.
Posted Jun 26, 2025 - 11:50 EDT

Investigating

UITS Staff are currently investigating an issue that is preventing the opening of SalesForce cases that initiate via email entry. Direct case creation from within Salesforce is still functional.
Posted Jun 26, 2025 - 11:06 EDT
This incident affects: UMSO Operational and Project Services (* UMPO Salesforce).