Citrix - Major Outage

Incident Report for UMass Shared Services

Resolved

Issues around Citrix connections have been resolved. Users are now be able establish new sessions in Citrix.

Thank you for your patience.
Posted Apr 24, 2026 - 21:02 EDT

Identified

Users are currently unable to open new session within Citrix. Microsoft Azure has identified this issue and is working to resolve as soon as possible. Thank you for your patience.
Posted Apr 24, 2026 - 15:29 EDT
This incident affected: UMSO Operational and Project Services (UMSO Citrix).