Student Services
Incident Report for UMass Shared Services
Resolved
This incident has been resolved.
Posted Jul 25, 2022 - 18:37 EDT
Investigating
We are currently investigating this issue.
Posted Jul 25, 2022 - 17:14 EDT
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell)).