UMSO VPN Degraded Performance
Incident Report for UMass Shared Services
Resolved
The underlying issue with UMSO VPN has been resolved. You may need to restore connectivity to UMSO VPN. Remember to log in using only your username and not your full email address.

We apologize for any inconvenience.
Posted Oct 14, 2021 - 16:44 EDT
Investigating
Multiple people have reported issues connecting to UMSO VPN. We are urgently investigating. We suggest that you continue to try and that you maintain an existing connection if possible.
Posted Oct 14, 2021 - 13:57 EDT
This incident affected: UMSO Network Services (UMSO VPN).