UMSO Dropbox - Partial Outage
Incident Report for UMass Shared Services
Resolved
the vendor resolved the incident. UMSO Dropbox is fully operational.
Posted Feb 07, 2023 - 14:20 EST
Investigating
Dropbox.com/work may not load and instead show 5xx error for some users. The vendor is aware and investigating.
Posted Feb 07, 2023 - 13:49 EST
This incident affected: UMSO Communication and Collaboration Tools (UMSO Dropbox).