Document Management - Degraded Performance

Incident Report for UMass Shared Services

Resolved

Softdocs has resolved the issue affecting Etrieve Central. Some users may have experienced issues editing forms, downloading forms or attachments, or exporting forms at the end of a workflow. The vendor has implemented a fix and confirmed that affected exports have been reprocessed. Etrieve services are operating normally. If you continue to experience issues, please submit an incident using the Document Management Support Form.
Posted Aug 18, 2026 - 13:46 EDT

Monitoring

There is an issue affecting Etrieve Central. The vendor has identified a potential cause and is currently testing a fix. Some Etrieve customers may experience intermittent issues accessing forms or other web-based functionality. We are monitoring the situation and will provide updates as additional information becomes available.
Posted Aug 18, 2026 - 12:01 EDT
This incident affected: Document Management (Boston, Dartmouth, Lowell).