Document Imaging (Boston, Dartmouth, Lowell) performance issue

Incident Report for UMass Shared Services

Resolved

The vendor has informed us that the document filing issue appears to have cleared. We are continuing to validate normal document filing with affected customers while monitoring the service.
Posted Jul 08, 2026 - 09:24 EDT

Investigating

Performance impacted. Actively working as an issue.
We have received reports of documents not filing as expected. A ticket has been opened and escalated with the vendor, and they are investigating.
Posted Jul 07, 2026 - 13:42 EDT
This incident affected: Document Management (Boston, Dartmouth, Lowell).