Student Production (Boston, Dartmouth, Lowell) Degraded Performance
Incident Report for UMass Shared Services
Resolved
The Student Production (Boston, Dartmouth, Lowell) system is available as of approximately 9:35 a.m. We will continue to closely monitor. We apologize for the inconvenience.
Posted May 25, 2021 - 09:44 EDT
Investigating
We are urgently investigating reports of slowness navigating within and logging into the Student Production (Boston, Dartmouth, Lowell) systems.
Posted May 25, 2021 - 09:13 EDT
This incident affected: Student Services (* Student Production (Boston, Dartmouth, Lowell)).