HR Direct - Degraded Performance
Incident Report for UMass Shared Services
Resolved
We resolved the HR Direct issue at approximately 12:35 p.m. today, Monday, 6/1/20. HR Direct is available. We will continue to closely monitor. We apologize for the inconvenience.
Posted Jun 01, 2020 - 13:24 EDT
Investigating
You may experience degraded performance when logging in or navigating pages in HR Direct. We are urgently investigating.
Posted Jun 01, 2020 - 09:16 EDT
This incident affected: Human Resources (* HR Direct).