UMSO VPN - Outage
Incident Report for UMass Shared Services
Resolved
UMSO VPN connections are available. We will continue to closely monitor and apologize for the inconvenience.
Posted Sep 23, 2022 - 11:03 EDT
Investigating
UMSO VPN connections are unavailable. People are timing out when initiating multi-factor authentication (DUO). We are urgently investigating this issue and apologize for the inconvenience.
Posted Sep 23, 2022 - 09:59 EDT
This incident affected: UMSO Network Services (UMSO VPN).