Terra Dotta - Study Abroad - Travel Registry Outage
Incident Report for UMass Shared Services
Resolved
Terra Dotta services, including Study Abroad and Travel Registry, were restored by the vendor.
Posted May 10, 2022 - 17:00 EDT
Investigating
Access to all Terra Dotta services will not be available for the next 2-3 hours, due to a vendor outage. An update will be provided when services are restored.
Posted May 10, 2022 - 14:49 EDT
This incident affected: International Services (* Terra Dotta - Travel Registry, * Terra Dotta - Study Abroad).