Multiple Applications - Degraded Performance
Incident Report for UMass Shared Services
Resolved
RESTORED: Our team continues to keep a close eye on the environment. We've observed that it has been stable and have seen consistent response times on our Finance, HR Direct, and Student (Boston, Dartmouth, Lowell) applications over the past week. Our vendors are working with us and we strongly believe a change made last week mitigated the impact. We continue to work with our vendors to identify and permanently fix the cause and prevent future disruptions.

We understand the importance of uninterrupted service and apologize for any inconvenience caused. Thank you for your patience and understanding throughout this process. If you experience any further issues or have any questions, please do not hesitate to contact us.
Posted Apr 06, 2023 - 16:22 EDT
Update
UPDATE: Our team continues to keep a close eye on the environment. We've observed that it has been stable and have seen consistent response times on our Finance, HR Direct, and Student (Boston, Dartmouth, Lowell) applications for the last 24 hours. Our vendors are working with us and we strongly believe a change made late yesterday afternoon helped solve the issue. We'll stay on high alert and will continually monitor until we get definitive answers from our vendors.
Posted Mar 28, 2023 - 16:35 EDT
Monitoring
Our team continues to closely monitor the performance of our applications. We have resumed processing the batch and are making real-time decisions as we gather logs and vendor recommendations to mitigate any instability. We understand the importance of uninterrupted service and are doing everything we can to get to the cause of these so that we minimize disruptions.

Once again, please accept our apologies for any inconvenience caused. We value your patience as we urgently work to address the cause of the performance issues.
Posted Mar 27, 2023 - 17:34 EDT
Identified
We are observing slowness in multiple applications when establishing new connections or navigating, including Finance, HR Direct, and Student (Boston, Dartmouth, Lowell). Non-critical batch jobs have been temporarily suspended as we urgently investigate this issue. We apologize for the inconvenience.
Posted Mar 27, 2023 - 10:10 EDT
Monitoring
Steps were taken this afternoon to stabilize the environment and we've observed improved performance of the applications. We continue to closely monitor the environment and will send another update tomorrow morning.
Posted Mar 22, 2023 - 13:44 EDT
Investigating
We are observing slowness in multiple applications when establishing new connections or navigating, including HR Direct and Student (Boston, Dartmouth, Lowell). We are urgently investigating and apologize for any inconvenience.
Posted Mar 22, 2023 - 10:04 EDT
This incident affected: Human Resources (* HR Direct) and Student Services (*Student Production (Boston, Dartmouth, Lowell)).