Citrix - Connection Issues and Degraded Performance

Incident Report for UMass Shared Services

Resolved

Issues surrounding Citrix connectivity have been resolved. Citrix functionality has been restored.
Posted Jun 08, 2026 - 10:52 EDT

Investigating

Users may experience degraded performance or issues connecting while using Citrix. We are actively working to resolve this issue.
Posted Jun 08, 2026 - 08:14 EDT
This incident affected: UMSO Operational and Project Services (UMSO Citrix).