Summit Student Batch is running late
Incident Report for UMass Shared Services
Resolved
Service now available.
Posted Jun 01, 2021 - 08:23 EDT
Monitoring
The Summit Student batch is running late. It is expected to finish by approx. 8:30 AM.
Posted Jun 01, 2021 - 07:28 EDT
This incident affected: Summit (* Summit - Student).