myUMB Applicant Portal - Outage
Incident Report for UMass Shared Services
Resolved
myUMB Applicant Portal is available. We apologize for the inconvenience.
Posted Jul 30, 2021 - 12:50 EDT
Investigating
System currently unavailable. Actively working as an issue.
Posted Jul 30, 2021 - 11:49 EDT
This incident affected: Student Services (myUMB Applicant Portal).